|
RIP and IGRP Redistribution Example: "from Cisco Docs"
Consider a WAN at a university that uses RIP as an interior
routing protocol. Assume that the university wants to connect
its wide area network to a regional network, 128.1.0.0, which
uses IGRP as the routing protocol. The goal in this case is to
advertise the networks in the university network to the routers
on the regional network. The commands for the
interconnecting router are listed in the example that follows:
router igrp 109
network 128.1.0.0
redistribute rip
!
default-metric 10000 100 255 1 1500
!
distribute-list 10 out rip
!
In this example, the router global configuration command
starts an IGRP routing process. The network router
configuration command specifies that network 128.1.0.0 (the
regional network) is to receive IGRP routing information. The
redistribute router configuration command specifies that
RIP-derived routing information be advertised in the routing
updates. The default-metric router configuration command
assigns an IGRP metric to all RIP-derived routes.
The distribute-list router configuration command instructs the
router to use access list 10 (not defined in this example) to
limit the entries in each outgoing update. The access list
prevents unauthorized advertising of university routes to the
regional network.
By default, the redistribution of default information between IP Enhanced IGRP
processes is enabled.
Simple DECbrouter Config example:
!
hostname BRUTC
!
!
interface Ethernet0
ip address 39.5.5.25 255.255.255.0
!
interface Serial0
ip address 1.1.1.2 255.255.255.0
encapsulation ppp
!
interface Serial1
ip address 2.2.2.2 255.255.255.0
encapsulation ppp
shutdown
!
router rip
redistribute igrp 1
network 39.0.0.0
network 1.0.0.0
!
router igrp 1
redistribute rip
network 2.0.0.0
network 1.0.0.0
!
!
end
BRUTC#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route
Gateway of last resort is not set
1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 1.1.1.0/24 is directly connected, Serial0
C 1.1.1.3/32 is directly connected, Serial0
R 2.0.0.0/8 is possibly down, routing via 39.5.5.30, Ethernet0
I 16.0.0.0/8 [100/8576] via 1.1.1.1, 00:00:41, Serial0
39.0.0.0/24 is subnetted, 1 subnets
C 39.5.5.0 is directly connected, Ethernet0
BRUTC#
|