|
Hi Davy,
On the DECbrouter if you set the interface as unnumbered Ethernet 0
and the network you want RIP to send and recieve updates on as the
IP network the Ethernet interface is in on the routers on both sides
of the WAN connection then RIP routing updates will work fine.
Regards,
o
/\_.
Neil Sheehan _-\-_|
NPS/NSTG Router Support (*)/ (*)
EX:
ROUTER A
!
interface Ethernet0
ip address 39.5.5.20 255.255.255.0
!
interface Serial0
ip unnumbered Ethernet0
!
interface Serial1
shutdown
!
router rip
network 39.0.0.0
!
BRUTC#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route
Gateway of last resort is not set
16.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R 16.0.0.0/8 [120/1] via 16.135.16.15, 00:00:26, Serial0
R 16.135.16.0/32 [120/1] via 16.135.16.15, 00:00:26, Serial0
39.0.0.0/24 is subnetted, 1 subnets
C 39.5.5.0 is directly connected, Ethernet0
ROUTER B
!
interface Ethernet0
ip address 16.135.16.15 255.255.255.0
lat enabled
!
interface Serial0
ip unnumbered Ethernet0
!
interface Serial1
shutdown
!
router rip
network 16.0.0.0
!
90T2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route
Gateway of last resort is not set
16.0.0.0/24 is subnetted, 1 subnets
C 16.135.16.0 is directly connected, Ethernet0
39.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R 39.0.0.0/8 [120/1] via 39.5.5.20, 00:00:09, Serial0
R 39.5.5.0/32 [120/1] via 39.5.5.20, 00:00:09, Serial0
From the Docs...
The network number specified must not contain any subnet
information. You can specify multiple network commands.
RIP routing updates will be sent and received only through
interfaces on this network.
RIP sends updates to the interfaces in the specified
network(s). Also, if an interface�s network is not specified, it
will not be advertised in any RIP update.
Example
The following example defines RIP as the routing protocol to
be used on all interfaces connected to networks 128.99.0.0
and 192.31.7.0:
router rip
network 128.99.0.0
network 192.31.7.0
|