| How to make an alternate copy of root disk with Advanced File system (AdvFs)
Assuming rz0 (Model rz26 - 1Gig) is your root disk., and you want
to make a new rz9 (Model RZ28 - 2Gig) as another copy of your system disk.
Currently certain version of Digital UNIX (formerly OSF/1) exists
on your "rz0" disk. Also, you are running AdvFS on both root and /usr
partitions and your primary swap may also be there on the system disk.
Also, this procedure works only if your sum of sizes of files on
the disk-1 is less than the total size of the target (disk-2), and
not using LSM. On SCSI based RAID disks., you are advised to
have root and swap partitions/domains only at Lun 0 (Logical Unit zero),
to properly work with existing versions of operating systems (until 4.0a)
1) You need to MAKEDEV for the new disk "rz9" as follows:
# cd /dev
# ./MAKEDEV rz9
2) Install the AdvFS boot-blocks on rz9 disk as follows:
(without bootblocks your disk can't load osf_boot and/or vmunix
properly thus failing to boot.)
# disklabel -rw rz9 RZ28 /mdec/rzboot.advfs /mdec/bootrz.advfs
You can also use SWXCR based disks (re) to boot., but you would
need to modify rzboot.advfs and bootrz.advfs to
reboot.advfs and bootre.advfs respectively, in the above command
(You can make modifications to partitions now if you want to
resize the partitions on this drive if needed. You can use
"disklabel -e /dev/rrz9c" if you want to make modifications
to the size of partition "a". Never attempt to change
the size of partition "c" and the "offset" of partitions
"a" and "c" unless you know what your are going to up against.
When editing the disk-label just change the size and offset
fields. After saving the disklabel if you read it again
the "cpg" field (example: "# (Cyl. 0 - 164*)" ) would
indicate if the partitions that you are going to use are
overlpapped or not to make sure you are not using overlapped
partitions to either store data or to mount!)
# /sbin/mkfdmn /dev/rz9a backup_root
# /sbin/mkfset backup_root root (You should not use other
file-set name, other than
whats shown here ie., root)
# /sbin/mkfdmn /dev/rz9g backup_usr
# /sbin/mkfset backup_usr usr
Notice that we are using same fileset name with a different
domain name as compared to the original system disk's domain
and fileset structure.
3) Copy the root file system to the rz9a partition:
a) Mount the newly created backup_root domain on /mnt
# /sbin/mount backup_root#root /mnt
b) Do the root file system copy to the /mnt as follows:
# /sbin/vdump 0f - / | (cd /mnt; /sbin/vrestore xf -)
(Notice that we are vdump'ing root_domain#root above
because it mounted on "/" as listed in /etc/fstab)
c) Check to see if files are present on the new disk/domain and
unmount the new disk/domain:
# cd /; /sbin/umount /mnt
d) Repeate steps (a),(b) and (c) for your /usr and/or /var partitions
(all domains/using-partitions on rz0 disk except for the swap)
4) If you want to boot from the new disk there are
few modifications you need to make:
Change the entries in /etc/fdmns/root_domain, /etc/fdmns/usr_domain
and/or /etc/fdmns/var_domain (including any domains that reside on the
disk rz0), the link /sbin/swapdefault, /etc/rc.config file for any
references that contain current system disk (rz0)
to the new disk (rz9). You need to modify the /etc/fstab
for swap partition information and any other UFS file-systems
on the system disk.
5) You probably have to find out any back-up scripts/custom programs
that reference to your original disk "rz0"., and change them
accordingly on the NEW domains/disk.
- Sri
---------------------------------------
Sridhar Chirravuri - OSF/Ultrix Support
Digital Equipment Corporation
Customer Support Center
ALF1-3/P26
5555 Windward Parkway West
Alpharetta, GA. 30201
1(800)354-9000 (Ext: 75386)
[email protected]
Standard Disclaimer Applicable
---------------------------------------
[Posted by WWW Notes gateway]
|
| re.1
Thank you for responding so quickly. I have one question regarding
the disklabel command, wouldn't disklabel -t advfs -rw disk# take
care of root boot_block?
Can you please tell me if I need the -t advfs option ifI follow your
instructions. If so, when would I use that option.
|